Recipe Not Saving

Discussion in 'Recipe Editor' started by bowlermj, Nov 6, 2019.

Tags:
  1. bowlermj

    bowlermj New Member

    Joined:
    Jan 14, 2019
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Saint Louis, MO
    I've been working on a recipe all evening and every time I make changes and save, it confirm the action but doesn't actually take hold. Upon reloading the recipe, all of my changes are gone. Even if I change the name, it may seem to work for a little while, but inevitably will revert back.

    Reference recipe: https://www.brewersfriend.com/homebrew/recipe/view/904846/working-title
     
  2. Yooper

    Yooper Administrator
    Staff Member

    Joined:
    Nov 16, 2013
    Messages:
    2,491
    Likes Received:
    1,581
    Trophy Points:
    113
    Gender:
    Female
    Occupation:
    Happily retired
    Location:
    Upper Michigan/Florida
    I can’t recreate the issue. What browser are you using, and what device/platform? I’ll look into this right away. I apologize for this happening, but we’ll correct it ASAP.
     
  3. Nosybear

    Nosybear Well-Known Member

    Joined:
    Jul 16, 2012
    Messages:
    9,400
    Likes Received:
    6,643
    Trophy Points:
    113
    Location:
    Aurora, CO, USA
    If it happens again, check for the little error banner at the top. It's at the very top of the recipe builder and very hard to see if you're saving from, say, the bottom of the recipe. A warning, it's not very informative but at least it will tell you why the recipe isn't saving.
     
    bowlermj likes this.
  4. bowlermj

    bowlermj New Member

    Joined:
    Jan 14, 2019
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Saint Louis, MO
    My apologies for the delay -- I'm about to try editing the recipe again for the first time in a few days and will let you know.

    I'm using Chrome (v78) in Windows 7 on a laptop.

    Thanks,
    Matt
     
  5. Craigerrr

    Craigerrr Well-Known Member

    Joined:
    Mar 14, 2018
    Messages:
    4,701
    Likes Received:
    6,903
    Trophy Points:
    113
    Just had this error message when trying to save a recipe. The adjustment I made was to unselect and reselect equipment profile. Samsung A70 (new device, OS up to date), using chrome browser
    Screenshot_20191116-153013_Chrome.jpg
     
  6. Nosybear

    Nosybear Well-Known Member

    Joined:
    Jul 16, 2012
    Messages:
    9,400
    Likes Received:
    6,643
    Trophy Points:
    113
    Location:
    Aurora, CO, USA
    That's the one that drives me up the wall! It's almost helpful...
     
  7. Ozarks Mountain Brew

    Staff Member

    Joined:
    Nov 20, 2012
    Messages:
    7,767
    Likes Received:
    3,976
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    IT Managment
    Location:
    The Ozark Mountains of Missouri
    Look at the error message, the wrong number of text or a space in the blank of other ingredients
     
  8. Pricelessbrewing

    Pricelessbrewing QA Software Tester
    Staff Member

    Joined:
    Jun 8, 2016
    Messages:
    766
    Likes Received:
    503
    Trophy Points:
    93
    Gender:
    Male
    @Craigerrr if you're able to replicate the issue could you make the recipe public?
     
  9. Craigerrr

    Craigerrr Well-Known Member

    Joined:
    Mar 14, 2018
    Messages:
    4,701
    Likes Received:
    6,903
    Trophy Points:
    113
    Recipe is public. As I noted, I only deselected, and then reselected the equipment profile. I had made some changes to the equipment profile. I made no adjustments to any ingredients. There is a bug, somewhere. I have had this happen a number of times before, but not under the same circumstance.
    This didn't create a big problem, thought I would bring it to your attention.
     
  10. Mark Farrall

    Mark Farrall Well-Known Member

    Joined:
    Oct 19, 2017
    Messages:
    1,303
    Likes Received:
    1,424
    Trophy Points:
    113
    Location:
    Melbourne Australia
    As Nosy said, this one is annoying. You do some random changes to the recipe in a session that's longer than a few minutes and you don't touch the other ingredients section and that message appears on save. You refresh the page, make your changes quickly and hit save and it works. It's one of those nightmare to reproduce bugs as it's got something to do with timings.

    You got anything with an each as a unit of measure in the other ingredients section? That's my latest (unsupported) theory.
     
    Pricelessbrewing likes this.
  11. Craigerrr

    Craigerrr Well-Known Member

    Joined:
    Mar 14, 2018
    Messages:
    4,701
    Likes Received:
    6,903
    Trophy Points:
    113
    I do have whirlfloc with each as the unit of measure. I have however made several other adjustments to this recipe (not to to whirlfloc), and had no issues with saving.
     
  12. BCBrewer

    BCBrewer New Member

    Joined:
    Apr 17, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I was getting this same error when attempting to add "0.5 tsp Irish Moss, 15 min, Fining, Boil" to the Other Ingredients section.
    Wouldn't let me save my changes unless I removed it.
    I had to close the tab and reopen the recipe, and re-add the Moss. Then it would let me save.
    I'm using Google Chrome if that matters at all.
     
  13. Yooper

    Yooper Administrator
    Staff Member

    Joined:
    Nov 16, 2013
    Messages:
    2,491
    Likes Received:
    1,581
    Trophy Points:
    113
    Gender:
    Female
    Occupation:
    Happily retired
    Location:
    Upper Michigan/Florida
    This is very strange. It's not happening to everyone using Chrome who has other ingredients in their recipe, but it seems to happen on occasion and that makes it very hard to pin down. I've put in a ticket and hopefully the devs can find the problem. Please let me know if anyone is experiencing this, and when it happens. That will help us find the issue.
     
  14. Nosybear

    Nosybear Well-Known Member

    Joined:
    Jul 16, 2012
    Messages:
    9,400
    Likes Received:
    6,643
    Trophy Points:
    113
    Location:
    Aurora, CO, USA
    I've experienced it from time to time but as you say, it's intermittent. I can't reproduce it myself.
     

Share This Page

arrow_white