Hop utilization weirdness

Discussion in 'Recipe Editor' started by nikseven, Jul 10, 2018.

  1. nikseven

    nikseven New Member

    Joined:
    Mar 20, 2015
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    3
    #1 nikseven, Jul 10, 2018
    Last edited: Jul 10, 2018
    Hi there!

    Just today I noticed some new odd behavior in the hop bill section of the recipe builder. Starting temp times for all additions are now defaulting to 212C, and my dry hop additions are suddenly showing a utilization of 0.070, where before they were 0. Even if I manually enter in 0% in the utilization field, it still shows Util. 0.070 at the bottom and is reflected in the total IBUs of my recipe.

    This issue is not just on new recipes, but also if I go to edit a saved recipe. I'll have a recipe (with a relatively heavy dry hop addition) that shows 38.48 IBU on the saved version, but as soon as I click edit that number jumps up to 86.17 IBU with the above temps and utilization figures! This is a big issue for me! I do a lot of updating and adapting of my recipes, and this really throws things out of whack!

    Something has definitely changed in the last week, since I brewed last Wednesday, adapting a recipe from a previous saved recipe, and did not have this issue. A friend of mine who also uses the software is having the exact same issue as well.

    Any insight on why this is happening?
     
  2. eheeke

    eheeke Member

    Joined:
    Mar 1, 2016
    Messages:
    55
    Likes Received:
    21
    Trophy Points:
    8
    Gender:
    Male
    Location:
    Hickory, NC
    I'm experiencing the exact same problem with hop utilization calculations. I just noticed it yesterday as I was updating some older recipes. It appears to affect both new and old. It only seems to impact the "Edit Recipe" mode.

    I've uploaded a 3-page PDF of an older recipe.
    1) On page 1 in "View Recipe" mode, all ingredients and hop utilizations show correctly.
    2) Page 2 shows the same recipe in "Edit Recipe" mode. Notice that the IBU jumps from 65.83 to 96.80 due to the program now calculating an IBU contribution from dry hops (which should be zero). The format of the hop input for the two "Boil" entries appears to have changed. This looks more like the format used for Whirlpool additions.
    3) Page 3 shows a recipe printout view that appears to be correct.

    On a side note, I've also had odd displays on the percentages shown for the fermentables on the "Edit Recipe" view. This has been going on longer than the hop utilization issue above. Intermittently the % showing for my steeping grains will be the actual % for my extract. On page 2 of my file you can see the 86.8% showing for the extract and both specialty grains.

    I hope this helps. If you have any questions, feel free to contact me. Thanks.
     

    Attached Files:

  3. Yooper

    Yooper Administrator
    Staff Member

    Joined:
    Nov 16, 2013
    Messages:
    2,326
    Likes Received:
    1,380
    Trophy Points:
    113
    Gender:
    Female
    Occupation:
    Happily retired
    Location:
    Upper Michigan/Florida
    We're looking at this now- thank you!
     
  4. Group W

    Group W Well-Known Member

    Joined:
    Sep 9, 2017
    Messages:
    1,359
    Likes Received:
    2,215
    Trophy Points:
    113
    Gender:
    Male
    Thank you Yoper!
     
  5. Yooper

    Yooper Administrator
    Staff Member

    Joined:
    Nov 16, 2013
    Messages:
    2,326
    Likes Received:
    1,380
    Trophy Points:
    113
    Gender:
    Female
    Occupation:
    Happily retired
    Location:
    Upper Michigan/Florida
    Ok, I think it's fixed now!

    All old recipes will not be changed. New recipes will not either, but you can set the utilization if desired to show those changes. Please try it, and let me know if you have any further issues.
     
  6. nikseven

    nikseven New Member

    Joined:
    Mar 20, 2015
    Messages:
    5
    Likes Received:
    1
    Trophy Points:
    3
    Awesome, thanks so much for the quick fix!
     
  7. gozer

    gozer New Member

    Joined:
    Oct 24, 2017
    Messages:
    16
    Likes Received:
    4
    Trophy Points:
    3
    I don't think this is fixed. Unless I'm having a different hop utilization issue. I have a recipe with 16g of Magnum at FWH (30m boil) and it's showing 100+ IBUs.

    This is happening on all my recipes.
     
    Hawkbox likes this.
  8. Group W

    Group W Well-Known Member

    Joined:
    Sep 9, 2017
    Messages:
    1,359
    Likes Received:
    2,215
    Trophy Points:
    113
    Gender:
    Male
    Thanks Yoper! I will play with utilization as you suggest. But it’s important to have reasonable defaults as a base.
     
  9. Group W

    Group W Well-Known Member

    Joined:
    Sep 9, 2017
    Messages:
    1,359
    Likes Received:
    2,215
    Trophy Points:
    113
    Gender:
    Male
    I had to edit (open the recipe) and then save it without making changes.
     
  10. gozer

    gozer New Member

    Joined:
    Oct 24, 2017
    Messages:
    16
    Likes Received:
    4
    Trophy Points:
    3
    I open and edit, but no change. Still showing 100+ IBUs for 16g of hops in a 24L batch.
    I even removed the hop addition and added it back. Jumps right up to 106.

    Weirdest part: the 5 min addition appears normal. 60g of Saphir adding 5 or so IBUs.

    I'd post a link to the recipe but the forum won't let me...
     
  11. Hawkbox

    Hawkbox Well-Known Member

    Joined:
    Jul 27, 2017
    Messages:
    3,380
    Likes Received:
    2,566
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    IT Manager
    Location:
    Edmonton
    I've definitely been noticing this too, it's weird as hell.
     
  12. Josh (Brewer's Friend)

    Josh (Brewer's Friend) Administrator
    Staff Member

    Joined:
    Nov 24, 2014
    Messages:
    183
    Likes Received:
    38
    Trophy Points:
    28
    Gender:
    Male
    Location:
    Saint Johns, FL
    Home Page:
    Apologies for the issues with IBU calculations. We had a feature requested to add the ability to customize utilization on hops entries. We were trying this out and it had some unintended side effects and the general feedback told us to roll this back immediately. We've since reverted to the original behavior, so things should be working as they did before. Please let us know if you still notice any issues. Thanks for bringing this to our attention, and apologies for the confusion.
     
    gozer likes this.
  13. Hawkbox

    Hawkbox Well-Known Member

    Joined:
    Jul 27, 2017
    Messages:
    3,380
    Likes Received:
    2,566
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    IT Manager
    Location:
    Edmonton
  14. Firehall Brewery

    Firehall Brewery New Member

    Joined:
    Sep 24, 2017
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    My recipes are still showing this issue, and would love to be able to get back to the original recipes. Anything I open to edit is getting screwed. What were the original default numbers for utilization and temp?
     
  15. avantassel

    avantassel Moderator
    Staff Member

    Joined:
    Jan 5, 2018
    Messages:
    146
    Likes Received:
    89
    Trophy Points:
    28
    Gender:
    Male
    Occupation:
    Brewer and Software Engineer
    Location:
    Lafayette, CO
    Home Page:
    Clearing out the input next to Scale Util will use the default utilization.
     
    Yooper likes this.

Share This Page

arrow_white