Robobrew died

Discussion in 'General Chit-Chat' started by Dog Hair Brewing Company, Apr 13, 2021.

  1. Dog Hair Brewing Company

    Joined:
    Jun 25, 2019
    Messages:
    6
    Likes Received:
    2
    Trophy Points:
    3
    Gender:
    Male
    Occupation:
    Retired Army
    Location:
    Orleans Ontario
    Hey Folks,
    Has anyone had to repair their Robobrew Gen3? I have replaced the Circuit board and the control screen and all I get is a error code?

    Any help would be great
     
  2. Craigerrr

    Craigerrr Well-Known Member

    Joined:
    Mar 14, 2018
    Messages:
    5,781
    Likes Received:
    8,641
    Trophy Points:
    113
    There are all kinds of YouTube videos on different issues and fixes, you may find some help there. You could also contact Kegland by emailing them, the address is on their site, and they are very responsive.
    Hope this helps
     
  3. Trialben

    Trialben Well-Known Member

    Joined:
    Mar 30, 2016
    Messages:
    9,712
    Likes Received:
    10,504
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    Pest control tech
    Location:
    Palmwoods QLD
    I agree I emailed them last week about a product and got a response same day.
     
    soccerdad likes this.
  4. Blackmuse

    Blackmuse Well-Known Member

    Joined:
    Jul 8, 2012
    Messages:
    952
    Likes Received:
    993
    Trophy Points:
    93
    Gender:
    Male
    Occupation:
    Electrician (Previously a 6th grade Teacher)
    Location:
    Maine
    Home Page:
    Just curious - what's the error code?
     
  5. Dog Hair Brewing Company

    Joined:
    Jun 25, 2019
    Messages:
    6
    Likes Received:
    2
    Trophy Points:
    3
    Gender:
    Male
    Occupation:
    Retired Army
    Location:
    Orleans Ontario
    E3
     
  6. Dog Hair Brewing Company

    Joined:
    Jun 25, 2019
    Messages:
    6
    Likes Received:
    2
    Trophy Points:
    3
    Gender:
    Male
    Occupation:
    Retired Army
    Location:
    Orleans Ontario
    Thanks folks have talked with kegland and was told double check the wiring.
    Going to try one more time.
     
    Trialben and Craigerrr like this.
  7. soccerdad

    soccerdad Well-Known Member

    Joined:
    Feb 24, 2015
    Messages:
    333
    Likes Received:
    481
    Trophy Points:
    63
    Location:
    South Georgia
    Good luck. My wife likes to tell me I'm wired the wrong way .. I hope that's not what you're getting here.
     
    Trialben likes this.
  8. Dog Hair Brewing Company

    Joined:
    Jun 25, 2019
    Messages:
    6
    Likes Received:
    2
    Trophy Points:
    3
    Gender:
    Male
    Occupation:
    Retired Army
    Location:
    Orleans Ontario
    upload_2021-4-14_14-28-50.png So checked the wiring and may have just been one wire in the wrong place, but am going to replace the thermo circuit just to make sure and if that doesn’t work guess I’ll have to bite the bullet and get a new one upload_2021-4-14_14-28-50.png
     
  9. Trialben

    Trialben Well-Known Member

    Joined:
    Mar 30, 2016
    Messages:
    9,712
    Likes Received:
    10,504
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    Pest control tech
    Location:
    Palmwoods QLD
    Positive is you'll never do that again.
    I'm sure I saw new brewzilla upgrade boards on their site the other day.
     
  10. Craigerrr

    Craigerrr Well-Known Member

    Joined:
    Mar 14, 2018
    Messages:
    5,781
    Likes Received:
    8,641
    Trophy Points:
    113
    Nothing was ever learned by doing it right the first time!
     
    Hawkbox, Head First and Trialben like this.
  11. Hawkbox

    Hawkbox Well-Known Member

    Joined:
    Jul 27, 2017
    Messages:
    4,065
    Likes Received:
    3,404
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    IT Manager
    Location:
    Edmonton
    There is never time to do it right, but there is always time to do it twice.
     
    Craigerrr and soccerdad like this.
  12. AGbrewer

    AGbrewer Well-Known Member

    Joined:
    Oct 19, 2018
    Messages:
    447
    Likes Received:
    315
    Trophy Points:
    63
    Did the rewire work after all or did you have to get a new one?
     

Share This Page

arrow_white