[Bug/Issue] Forum Topic Subscription Emails

Discussion in 'Feature Requests' started by cearum, Aug 1, 2013.

  1. cearum

    cearum Member

    Joined:
    Jul 11, 2012
    Messages:
    102
    Likes Received:
    1
    Trophy Points:
    16
    Location:
    Metro Detroit, MI
    I'm not sure where the best place to put this; so I'm putting it here.

    I keep getting emails for a topic that I am no longer subscribed to stating that there are new posts. First of all, there aren't any new posts on the topic. Second, I'm not subscribed to any topics as I cleared them out in my forum settings. I'd be happy to provide more information as this isn't a lot to go on right now.
     
  2. LarryBrewer

    LarryBrewer Active Member

    Joined:
    Jun 27, 2012
    Messages:
    1,728
    Likes Received:
    9
    Trophy Points:
    38
    Location:
    Portland, Oregon
    We'll look into it today.
     
  3. Ozarks Mountain Brew

    Staff Member

    Joined:
    Nov 20, 2012
    Messages:
    7,485
    Likes Received:
    3,674
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    IT Managment
    Location:
    The Ozark Mountains of Missouri
    still happening to me too but I just ignore the path and indeed there is new posts just here which is fine for me
    search.php?search_id=newposts
     
  4. LarryBrewer

    LarryBrewer Active Member

    Joined:
    Jun 27, 2012
    Messages:
    1,728
    Likes Received:
    9
    Trophy Points:
    38
    Location:
    Portland, Oregon
    This has been a tricky one to track down. Thank you both for reporting this. We are now keeping a close eye on all notifications that go out, to try and narrow it down.
     
  5. LarryBrewer-Testing

    LarryBrewer-Testing New Member

    Joined:
    Jun 27, 2012
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Test reply by LarryBrewer using a test account.
     
  6. LarryBrewer-Testing

    LarryBrewer-Testing New Member

    Joined:
    Jun 27, 2012
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    And this came back, which is correct:


     
  7. Ozarks Mountain Brew

    Staff Member

    Joined:
    Nov 20, 2012
    Messages:
    7,485
    Likes Received:
    3,674
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    IT Managment
    Location:
    The Ozark Mountains of Missouri
    try subscribing to more than one post
     
  8. LarryBrewer

    LarryBrewer Active Member

    Joined:
    Jun 27, 2012
    Messages:
    1,728
    Likes Received:
    9
    Trophy Points:
    38
    Location:
    Portland, Oregon
    Good idea, just did that.

    I did correctly get both notification emails just now when you posted (to my main account and my test account).

    It is one of those computer problems that goes away as soon as I look at it! :lol:
     
  9. cearum

    cearum Member

    Joined:
    Jul 11, 2012
    Messages:
    102
    Likes Received:
    1
    Trophy Points:
    16
    Location:
    Metro Detroit, MI
    I haven't gotten one in a while, so maybe it's fixed now? I know it happened for a few days after I unsubscribed to the post. I'll keep an eye out and I can update if something happens again.
     
  10. Ozarks Mountain Brew

    Staff Member

    Joined:
    Nov 20, 2012
    Messages:
    7,485
    Likes Received:
    3,674
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    IT Managment
    Location:
    The Ozark Mountains of Missouri
    I'm subscribed to this post but didn't get the last 2 emails after mine, is it off now?
     
  11. LarryBrewer

    LarryBrewer Active Member

    Joined:
    Jun 27, 2012
    Messages:
    1,728
    Likes Received:
    9
    Trophy Points:
    38
    Location:
    Portland, Oregon
    Nope didn't change anything yet.
     
  12. LarryBrewer

    LarryBrewer Active Member

    Joined:
    Jun 27, 2012
    Messages:
    1,728
    Likes Received:
    9
    Trophy Points:
    38
    Location:
    Portland, Oregon
    I noticed a few incorrect emails came to me today and compared the log information. I believe the problem is triggered when a user is subscribed to multiple threads (thank you QHB), and that thread that has multiple subscribers.

    I made a minor adjustment just now, we'll see if that takes! Stay tuned and sorry about the incorrect emails the system is generating. If this works we may re-enable forum level subscriptions.
     
  13. LarryBrewer-Testing

    LarryBrewer-Testing New Member

    Joined:
    Jun 27, 2012
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
  14. LarryBrewer-Testing

    LarryBrewer-Testing New Member

    Joined:
    Jun 27, 2012
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
  15. Ozarks Mountain Brew

    Staff Member

    Joined:
    Nov 20, 2012
    Messages:
    7,485
    Likes Received:
    3,674
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    IT Managment
    Location:
    The Ozark Mountains of Missouri
    storm knocked out power out all night till 8 am , got 2 emails from the correct post, this one this morning :) the time on the emails say 2:19 and 2:24 am
     
  16. Ozarks Mountain Brew

    Staff Member

    Joined:
    Nov 20, 2012
    Messages:
    7,485
    Likes Received:
    3,674
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    IT Managment
    Location:
    The Ozark Mountains of Missouri
    got another from this last post at 10:42
     
  17. LarryBrewer

    LarryBrewer Active Member

    Joined:
    Jun 27, 2012
    Messages:
    1,728
    Likes Received:
    9
    Trophy Points:
    38
    Location:
    Portland, Oregon
    It appears to be working more accurately, but I'm not 100% satisfied. I think the issue with the wrong topic name being sent out is fixed. So, still watching this one...

    The emails go into a queue and sometimes take up to an hour to be sent. Generally it is pretty quick though.
     
  18. Ozarks Mountain Brew

    Staff Member

    Joined:
    Nov 20, 2012
    Messages:
    7,485
    Likes Received:
    3,674
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    IT Managment
    Location:
    The Ozark Mountains of Missouri
    very strange I'm getting about 2 out of 10 right, I was getting my own post email back at one time, now nothing at all lol
     
  19. LarryBrewer

    LarryBrewer Active Member

    Joined:
    Jun 27, 2012
    Messages:
    1,728
    Likes Received:
    9
    Trophy Points:
    38
    Location:
    Portland, Oregon
    I just got the email notification from your last post about 15 minutes later.

    There are a few more things I can change to make it run better I think.

    It depends if you have been back to the forum recently, and also if you have 'notify my when a reply is posted', vs just being subscribed to the thread.

    EDIT: and then it emails me when I reply to the topic... (must be because I am subscribed to it). This may be another bug I can try to narrow down.
     
  20. Ozarks Mountain Brew

    Staff Member

    Joined:
    Nov 20, 2012
    Messages:
    7,485
    Likes Received:
    3,674
    Trophy Points:
    113
    Gender:
    Male
    Occupation:
    IT Managment
    Location:
    The Ozark Mountains of Missouri
    weird I did not get this email but I'm subscribed and notify me is always checked
     

Share This Page

arrow_white