Water requirements off - not a screen vs print issue

JoeSchmoe

New Member
Trial Member
Joined
Nov 1, 2013
Messages
7
Reaction score
0
Points
1
Hello all,

I'd like to report what seems to be a pretty significant error in the Water Requirements calculator.

Hopefully you can see in the attached image, the left side shows the Water Requirements calculation for a recent brew session. I nearly missed my final gravity pretty significantly (and ended up having to boil an additional 20 minutes) by following these incorrect results.

I'm pretty confident that this is a bug because 7.57 gal at 1.027 and reduced by 1.4 gal only results in a 1.033 final gravity - pretty far off from my desired 1.041 (see the bottom right of the image showing BF's boil off calculator with these numbers). In order to hit my desired gravity, I actually needed to boil off 2.58 gal but then that caused me to miss my expected volume (shown in the top-right of the image - again using BF's boil off calculator). Added to that, my equipment profile's boil rate (which is fairly accurate) is not nearly high enough to boil 2.58 gal in 60 minutes.

Let me know if there is any more information I can provide to help track this down.
 

Attachments

  • Brew_Session___Brewer_s_Friend_and_Dilution_And_Boiloff_Gravity_Calculator_-_Brewer_s_Friend.jpg
    Brew_Session___Brewer_s_Friend_and_Dilution_And_Boiloff_Gravity_Calculator_-_Brewer_s_Friend.jpg
    240.3 KB · Views: 38
Thanks @JoeSchmoe, I was able to figure where the error is happening here which is actually with the preboil calculation. The recipe was missing a postboil volume and the 0 was causing some issues in our calculations.

Note that if your OG was accurate after your adjustments with the boil time and your volume was off, then you might need to take a look at your efficiency value as the total gravity points don't line up here if your losing a gallon to kettle losses.


Incorrect
upload_2023-6-15_20-19-4.png





Correct
upload_2023-6-15_20-19-55.png
 
@Pricelessbrewing That was it! Thanks for taking such a detailed look at this to figure it out.

I see that a lot of my recipes have no value (implied zero, I guess) for the post-boil amount, and honestly I don't recall ever seeing this field or filling it out in the past (though I have been away from BF for a while...)

I wonder if there is a way to flag this to the user so that they are aware that it could cause issues. Maybe some warning message in the Water Requirements tab on the brew session? Or perhaps a missing post-boil value could just be considered as having the "auto" calculation enabled, and that value could be used for the water requirements calculations? What do you think?
 
@Pricelessbrewing That was it! Thanks for taking such a detailed look at this to figure it out.

I see that a lot of my recipes have no value (implied zero, I guess) for the post-boil amount, and honestly I don't recall ever seeing this field or filling it out in the past (though I have been away from BF for a while...)

I wonder if there is a way to flag this to the user so that they are aware that it could cause issues. Maybe some warning message in the Water Requirements tab on the brew session? Or perhaps a missing post-boil value could just be considered as having the "auto" calculation enabled, and that value could be used for the water requirements calculations? What do you think?
I've already created a request to the developer to implement that exact solution :) Appreciate the reply and assistance!
 

Back
Top