IBU applied to dry hop addition when hop copied over from Whirlpool

Discussion in 'Recipe Editor' started by Rob S, May 15, 2020.

  1. Rob S

    Rob S New Member

    Joined:
    Jul 7, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I copied the hops from my whirlpool additions then changed it to dry hop and the hop IBU carried over but didn't get reset when I changed the addition to dry hop. This has incorrectly calculated the IBU for the recipe.
     

    Attached Files:

  2. Yooper

    Yooper Administrator
    Staff Member

    Joined:
    Nov 16, 2013
    Messages:
    2,486
    Likes Received:
    1,566
    Trophy Points:
    113
    Gender:
    Female
    Occupation:
    Happily retired
    Location:
    Upper Michigan/Florida
    Can you please give me a link to the recipe as well, so I can dig into it?
     
  3. Mark Farrall

    Mark Farrall Well-Known Member

    Joined:
    Oct 19, 2017
    Messages:
    1,302
    Likes Received:
    1,423
    Trophy Points:
    113
    Location:
    Melbourne Australia
    There's a Hop Options section in the equipment profile that allows you to set a utilisation for hops added at various stages (https://www.brewersfriend.com/homebrew/profile/equipment). It defaults to 5% for dry hop. So it may be that rather than the copying creating those numbers. You can set it to 0 or leave it at 5 as you prefer.

    I think this is a relatively new behaviour and being looked at currently.

    I suppose the 5% may make sense from an IBU assay point of view, but so much of the thinking from 10 years or more ago assumes that there's 0 IBUs from dry hopping. It probably also throws off style guidelines and the style tickbox as they'd assume 0 IBUs for dry hopping.
     
  4. Rob S

    Rob S New Member

    Joined:
    Jul 7, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
  5. Pricelessbrewing

    Pricelessbrewing QA Software Tester
    Staff Member

    Joined:
    Jun 8, 2016
    Messages:
    764
    Likes Received:
    502
    Trophy Points:
    93
    Gender:
    Male
    Thanks for the report, I'm adding this forum thread to a ticket.

    The issue is the Util (optional): field gets filled in as 10% for whirlpool additions, but doesn't get reset when changing from whirlpool to something else. You'll see the same issue if you change the whirlpool addition to a boil addition.

    @Yooper this is issue #1367.
     
    Yooper likes this.
  6. Rob S

    Rob S New Member

    Joined:
    Jul 7, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ok great thanks. I will manually change the utilization on this recipe for now
     
  7. Pricelessbrewing

    Pricelessbrewing QA Software Tester
    Staff Member

    Joined:
    Jun 8, 2016
    Messages:
    764
    Likes Received:
    502
    Trophy Points:
    93
    Gender:
    Male
    An update has been released to resolve this. Going forward, the utilization % will automatically reset when changing the hop additions use type.

    @Rob S
     
    Yooper likes this.

Share This Page

arrow_white